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Thank you for purchasing the IV-S30SP, which is parameter setting support software for the IV series.

Read this manual thoroughly to understand the features and operation of this software completely.

Keep this manual for future reference. We are confident that this manual will be helpful whenever you

encounter a problem.
Store this user’s manual in a safe place. We are confident that the manual will be helpful whenever you
encounter a problem.
In addition to this manual, there are other IV-S30/C35M/S20 manuals as follows. Read them in conjunction
with this manual.

- IV-S30 (IV-S31M/S32M/S33M) User’s Manual (Introduction and hardware)
User’s Manual (Function and operation)

- IV-S30 (IV-S31MX/S32MX/S33MX) User’s Manual (Introduction and hardware)
User’s Manual (Function and operation)

- IV-S20

- IV-S30 (IV-S30J) User’s Manual (Introduction and hardware)
User’s Manual (Function and operation)

- IV-C35M User’s Manual (Introduction and hardware)
User’s Manual (Function and operation)

Introduction Manual 
User’s Manual 

Software version
This manual describes version 3.06 of the IV-S30SP system software. The details of the upgrade from
version 2.20 are as follows.

 Added functions in version 3.06 (compared with version 2.20)
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Note

- This manual is written with the utmost care. If you note something wrong or unclear,
please contact the sales shop or service company.

- No part of this manual may be reproduced in any form without written permission from
SHARP corporation.

- The contents of this manual are subject to change without prior notice.
- We are not liable for any damage, lost profits or charges made by third parties which may

be caused by using this software.



Item
Model

CPU

Operating system

Memory
Hard disk

Display

CD-ROM drive
RS-232C port

Mouse

Printer

Specification
IBM PC/AT or compatible machines

Pentium 90 MHz minimum (recommend Pentium 133 
MHz or better)
Microsoft Windows Me, Microsoft Windows 2000
Microsoft Windows NT4.0, Microsoft Windows 95/98

32 M-bytes minimum (recommend 48 M-bytes or more)
30 M-bytes or more free space

SVGA or more (Resolution: 800 x 600 pixels, 256 col-
or or more) Recommended color monitor display: High 
color (16 bits) or better

Needed to install this software
One port or more

A mouse or pointing device compatible with the 
Windows95/98/NT4.0 environment.

A printer compatible with the Me/2000/NT/98/95 envir-
onment.

USB port One port recommended (only Windows Me/2000/98 
supports the USB interface)

■■■■■     Operating environment
This software runs on any computer, which is equipped with the following operating environment.

· Windows is a registered trade mark of Microsoft Corporation, USA.

· Pentium is a registered trade mark of Intel Corporation, USA.
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Preface

Preface
This software (IV-S30SP) is a parameter setting support software used to specify the parameters for the com-

pact image sensor camera IV-S30/C35M/S20. It runs on Windows Me/2000/NT4.0/98/95 platforms, and allows

users to specify data, and manage and analyze inspection results, using a personal computer.

[1] Features
- Its offline setting function allows you to specify and change object type conditions without halting a

production line.

- Its automatic document creation function allows you to manage and save the parameter settings.

- Its measurement data collection function can transmit measurement results from the IV-S30/C35M/S20

to a personal computer.

- Its parameter data upload/download function enables you to send samples via e-mail for evaluation of

sample measurements, and to copy data easily to other IV-S30/C35M/S20 controllers.

- Its image data output function can print a captured image using a personal computer.

- The IV-S30/C35M/S20 system software upgrade function allows you to upgrade the system functions

and resolve problems easily.

- The menu customization function allows you to customize the operation screens (user menu editor).

- Use of the USB interface increases the data transfer speed dramatically (Windows Me/2000/98 only on

the IV-S30/C35M).

- There are two versions of the IV-S30SP program: one for the IV-S30/C35M and the other for the IV-S20.

The table below describes the differences.

 [Function comparison between the IV-S30/C35M and IV-S20 program versions]

noitcnuF M53C/03S-VI 02S-VI
noitcnufgnittesretemaraP O O

noitidnocepyttcejbO- O O
noitidnoclabolG- O X
egamiecnerefeR- O O

sretemarapevas/daoL O O
egassemdnaegamiyalpsidevas/daoL O O

noitcnufnoitaerctnemucoD O O
noitcnufnoitcellocataD O O

noitcnufrotideunemresU 1* X
noitcnuftsetdnammoC O O

noitcnufedargpU O O
tnirP O O

egnahcrolocegasseM O O
mooZ O X

ssenthgirbegamiegnahC O O
egapbeWSMSotkniL O X

dracyromeM 2* X

* 1: The user menu editing function can be used when any IV-S31M/S32M/S33M is used as the controller.

* 2: The memory card can only be used when the IV-C35M is used as the controller.

Note

In this manual, the term "IV-S30/C35M" refers to the following controller models.
emanledoM rellortnoC

M53C/03S-VI
03S-VI

M33S/M23S/M13S-VI
XM33S/XM23S/XM13S-VI

J03S-VI
M53C-VI M53C-VI
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[2] Operating environment
This software runs on any computer, which is equipped with the following operating environment.

· Windows is a registered trademark of Microsoft Corporation, USA.

· Pentium is a registered trademark of Intel Corporation, USA.

[3] System configuration
 System connections on the IV-S30(except IV-S30J)/C35M

(RS232C/RS422)

IV-S30 main housing
(Side view)

*1
RS-232C communication cable

Controller: IV-S33MX etc.
(Top view)

This software
(IV-S30SP)

Communication
connector

Personal computer 
IBM PC/AT (or compat-

ible machines)

*1
USB cable

IV-S3＊M

OUTPUT

INPUT

POWER

Y7Y0 Y1 Y2 Y3 Y4 Y5 Y6 COM

COM ＋24VX7X0 X1 X2 X3 X4 X5 X6

READY 0V

VIDEO CAMERA1 CAMERA2
USB
RS232C/RS422 REMOTE

Communication
connector

(USB)

For details about the wiring, see section "Connection with personal computer" in the 
user’s manual of each controller (Introduction and Hardware).

*1: A USB cable and an RS-232C communication cable are 
accessories that come with this software package.

Item
Model

CPU

Operating system

Memory
Hard disk

Display

CD-ROM drive
RS-232C port

Mouse

Printer

Specification
IBM PC/AT or compatible machines

Pentium 90 MHz minimum (recommend Pentium 133 
MHz or better)
Microsoft Windows Me, Microsoft Windows 2000
Microsoft Windows NT4.0, Microsoft Windows 95/98

32 M-bytes minimum (recommend 48 M-bytes or more)
30 M-bytes or more free space

SVGA or more (Resolution: 800 x 600 pixels, 256 col-
or or more) Recommended color monitor display: High 
color (16 bits) or better

Needed to install this software
One port or more

A mouse or pointing device compatible with the 
Windows95/98/NT4.0 environment.

A printer compatible with the Me/2000/NT/98/95 envir-
onment.

USB port One port recommended (only Windows Me/2000/98 
supports the USB interface)
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[4] Product components
One CD-ROM

One Instruction manual

One RS-232C communication cable (1.5 m)

[Connector --- 9-pin D-sub male (IV-S30/S20 side) + 9pin D-sub female (PC side)]

One USB cable (3 m)

[5] User file
Shown below are the user file types, which can be read and written using this software.

noitacifissalC noisnetxE

)sretemarapM53C/03S-VI(eliftcejorP mpa

egamiyalpsiD pmb

tsetdnammoC tst

erawfosmetsys02S/M53C/03S-VI tom

noitcerrocatad/tnemucoD vsc

noitidnocgnittesepyttcejbO rsm

noitidnoclabolG mrp

egamiecnerefeR pmb

Y0 Y1 Y2 Y3 Y4 Y5 Y6 Y7 BUSY C(－)
X0 X1 X2 X3 X4 X5 X6 C(＋) ＋24V 0V

IV-S20

VIDEO CAMERA1 CAMERA2 RS232C/RS422 REMOTE

POWER

OUTPUT

INPUT POWER

▼ ▼

(RS232C/RS422)

IV-S20 main housing, IV-S30J
(Side view)

*2 RS-232C communication cable

IV-S20 main housing, IV-S30J
(Top view)

This software
(IV-S30P)

Communication
connector

Personal computer 
IBM PC/AT (or 
compatible ma-

*2 An RS-232C communication cable is an accessory that comes with this software.
For details about the wiring, see section "Connection with personal computer" in the IV-S20 
user’s manual.

- System connections on the IV-S20, IV-S30J
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Face the CD-ROM 
label side up.

Setup
The installation process that places a program on a computer and makes it ready for use is referred to as the

"Setup." This chapter describes the setup procedure.

This software runs on the Windows Me/2000/NT/98/95. The descriptions in this chapter use a Windows98

installation for the example.

Note: Before starting the installation, disable any virus check programs in your computer.

[1] Installation of the IV-S30SP
1. Start up the Windows98, and place the IV-S30SP CD-

ROM on the CD-ROM drive.

Note: Do not put any labels on the CD-ROM.

2. Double-clicks the CD-ROM drive icon on the Windows

desktop.

You will find folders for both the IV-S20 and IV-S30/C35M

on the CD-ROM (see below).

Refers to the IV-S20 version in this manual

Refers to the IV-S30/C35M version in this manual

- When using the IV-S30/C35M

Open the [IV-S30] from [IVS30SP] folder on the CD-ROM. Then double-click on "setup.exe." - Go to

step 3.

- When using the IV-S20 (English)

Open the [IV-S20]-[English] from [IVS30SP] folder on the CD-ROM. Then open the [ENGLISH] folder.

Double-click on "setup.exe." - Go to step 4

3. Select the OS type that you have and specify Japanese or English.

The descriptions below explain the use of the software on the IV-S30/C35M.

(When the upgrade software for the IV-S20 is installed, the term "IV-S30SP" in the messages will

change to "IV-S20SP.")

4. The setup program will startup and prepare the setup wizard.

After the setup preparation is complete, the dialog box

shown on the right will appear.
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5. Click the "Next" button. The following dialog box will appear.

6. When you do not need to change the folder (directory) where you want to install the program, simply

click the "Next" button to continue the installation.

To change directory, click on the "Browse..." button. The

"Choose Folder" dialog box will appear. Select the drive

and directory, and click on the "OK" button. Then click

on the "Next" button to continue.
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7. By clicking on the "Next" button, the "Select Program Folder" dialog box will appear.

8. When you do not want to change the program folder, simply click on the "Next" button to continue the

installation.

To change the folder, enter a new folder name, or select a folder from the existing folder list. Then click

on the "Next" button to continue installing the program.

After the setup is complete, the following dialog box will appear.

9. Click on the "Finish" button to return to the initial setup screen.
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10. To start this program, bring up the start menu in Windows98, and then select "Programs" - "Sms" -

and "IVS30SP" in that order.

The program will start and the following screen will appear.

- Screen for the IV-S20 (See page Setup-1.)

11. To quit this program, select the "File" - "Exit" item from the menu bar.

- Screen for the IV-S20 (See page Setup-1.)

- The confirmation dialog box will appear.

· Click on the "Yes" button to stop this program.
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· You can also stop the program by clicking on the " " button in the upper right corner of the window.

- The confirmation dialog box will appear. Click on the "Yes" button.

[2] Setting the Windows environment
1. From the scroll bar menu, select "Settings" and then "Control Panel ."

2. Open the "Display Properties" menu and click on the "Settings" Tab. Then, set the number of colors in

the "Color palette" and the font size in "Font size."

Click here

Please select "Small Fonts."

Please select "256 Color."
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[3] Installation of a USB driver (version for the IV-S30/C35M)
1. Turn ON the power to the controller (IV-S33MX etc., except IV-S30J).

2. After turning ON the power, connect the personal computer to the controller using the USB cable. The

[Add New Hardware Wizard] dialog box will appear, and it will display an "Unknown Device" message.
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3. Click on the [Next] button. The display will change to the screen for selecting a search method. Select

"Search for the best driver for the device. [Recommended]," and click on the [Next] button.

4. A USB device driver is stored on the IV-S30SP CD-ROM. If the CD-ROM drive in your personal

computer is labeled E, enter "E:\driver" for the search location. Then click on the [Next] button.

5. "ivs30usb Device" will appear. Click on the [Complete] button to finish the setting.
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6. To make sure that the setting is completed correctly, select [System] from [Control Panel] and exam-

ine the device tree in the Device Manager. If the "Ivs30usb Device" icon is displayed as shown in the

figure below, installation of the device driver is complete.



■ Version for the  
IV-S30/C35M
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After starting this software (for the IV-S30/C35M), the screen shown below will appear. The menu organization

on the menu bar is also shown below.

The following menus (1) to (7) correspond to the items on the next page.

- This screen will be displayed when this software (for IV-S30/C35M) is started.

(1) (2) (3) (4) (5) (6) (7)
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(1) File

(2) Edit

Cut  � Ctrl + X� Copy the image displayed on the IV-S30SP to the clipboard and 
� delete it after it is pasted elsewhere.

Copy� Ctrl + C � Copy the image displayed on the IV-S30SP to the clipboard.

Paste� Ctrl + V � Paste the IV-S30SP image currently being held on the clipboard.

Add � Add an object type to the object type conditions.

Delete � Delete the image currently displayed on the IV-S30SP.

Print � Ctrl+P� Print

Open� Ctrl+O� Open an existing image file. (*.bmp/*.msr/*.prm)

Save display image �Ctrl+S� Save only the currently displayed image.

Open project (W) � Open a project file, such as the controller parameters.

Save project (V) � Save a project file, such as the controller parameters.

Save As project (E) � Save a project file, such as the controller parameters using a 
� new file name.

Close project (K)� Close a project file, such as the controller parameters.

Properties (I) � Display the current project and model names (IV-S33MX etc.).

Page setup� Specify the pages to print.

(Description)

New� Ctrl + N� Create a new file.

Exit �� Quit the IV-S30SP.

(Description)
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(3) View (display)

(4) IVS30 communication

Toolbars  

Standard� Select whether or not to display the standard tool bar.

Display image� Select whether or not to display the tool bar used for displaying an�
� image.

Status Bar (S)� Select whether or not to display the status bar.

Display image monitor� Select whether or not to display the image window for monitoring.

Parameter List� Select whether or not to display the parameter list box.

Zoom In� Zoom in closer to an image.

Zoom Out� Zoom back away from an image.

Zoom Magnification Rate� Select an image size: 25, 50, 75, or 100% of normal.

100%, 75%, 50%, 25%

Display image Brightness Level� Change the image brightness between standard and one-half of normal.

Standard, 1/2

Message Color (C)� Change the message display color to the specified color. 

Black, Blue, Green, Cyan, Red, Magenta, Yellow, White

IVS30 data transfer

Write� Send a set of parameters or an image from the PC to the controller.

Read� Read a set of parameters or an image from the controller.

Verify� Verify that the parameters or image in the  PC is the same as that in �
� the controller .

Initialize� Initialize the parameters or images in the controller.

Self Test� Have the controller check its own parameters and image conditions.

Version grade� Upgrade the system software in the controller.

Option� Specify the communication, IV data transfer, and upgrade conditions. 

　　

(Description)

(Description)
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(5) Tools

(6) Window

(7) Help

Contents� Display the table of contents for the Help files.

Contents and Index� Display the help menu search topic screen.

SMS Web page� Look at the SMS web site.

About IV-S30SP� Display the version information for the IV-S30SP program.

Cascade display� Overlap the open windows.

Tile Vertically� Display the open windows in a vertical layout.

Tile Horizontally� Display the open windows in a horizontal layout.

(Description)

 Command Test � Test the communication between the controller and a personal 
computer.

Data collection� Send the measurement execution data from the controller to a 
personal computer and total the data.

Create document � Create a document using the current IV parameter details.

User menu editor� Create or modify IV menus and messages.

(Description)

 

(Description)

 

Reads, saves, and deletes data from a flash memory card.

(IV-S31M/S32M/S33M)

Memory card 
(IV-C35M)
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Chapter 2: Optional Settings
When you communicate between the personal computer and the IV-S30/C35M, you must specify the commu-

nication conditions for IV-S30/C35M data transfers, and software upgrades.

- For details about setting the specific controller model, see page 5-2.

2-1 Specify the communication conditions
Click on the "Option" in the "IVS30 communication" menu.

- The "Option" dialog box will appear.

Ë Serial communication

Select "Serial" for the "COMM method" and specify the other communication conditions.

Note: Make sure to specify the same communication conditions as previously specified in the [COMM. SET]

item on the IV-S30/C35M’s [SYSTEM COND] menu.

Click here

Click here
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Ë USB communication

Select "USB" for the "COMM method" and specify the other communication conditions.

USB data transfer

- Only: Only transfer data to the IV-S30/C35M that have been specified in the "Station" assignments.

- All: Transfer data to all of the IV-S30/C35M controllers that are connected to the USB cables.

Click here
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2-2 Transfer conditions
Select "IV-S30/C35M transfer conditions" from the "Option" dialog box and specify the other transfer

conditions in the window.

(When the IV-C35M is specified as the controller model to use)

[Parameter] = All parameters specified in the IV-S30/C35M

Object type conditions:The conditions specified for each object type (measurement conditions, etc.)

Global conditions: The shared conditions which are set and applied to all object types (system con-

ditions, etc.)

Reference image: Any reference image registered in the IV-S30/C35M

Title & Character: Transfers all the titles and character strings used with the IV-S30/C35M (Since it

takes a long time to transfer the data, we recommend that you should not read it

out if you did not changes the titles or character strings.)

Wizard sample (except for the IV-S31M/S32M/S33M)

: Samples that were registered using the set wizard function.

[Gray scale image] = 256 intensity levels (When the IV-C35M is used, this item will read: [Color/

gray image].)

Capture: Store the image displayed on the MAIN OPS MENU.

Pre-process:An image processed by making shading corrections and binary image masking.

Rotated: Change the base angle on a captured image.

Work area: The portion of an image used for making measurements.

* Select either "Capture all images" or "Capture partial image."

[Binary image]

Pattern:   Displays a frame around the search area of the image to be measured on the MAIN OPS

  MENU.

Character:   Characters displayed on the IV-S30/C35M screen.
Binary image: An image that has been captured and processed by binary conversion.

[NG images] = Images captured by the IV-S30/C35M that fail some measurement criteria.
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2-3 Upgrade conditions
Select "Software upgrade conditions" in the "Option" dialog box and specify the other upgrade conditions

in the window.

[Upgrade version type]

No initialization: Do not initialize the IV-S30/C35M.

All initialization: Initialize the IV-S30/C35M.

[Program used to send data]

Boot: IV-S30/C35M boot program

System: IV-S30/C35M system program



3-1

Chapter 3: Parameter Settings

3

IV
-S

30
/C

35
M

Chapter 3: Parameter settings
Set object type conditions (Measurement conditions, Evaluation conditions, Numerical conditions, and output

conditions).

- You can set and change the conditions offline. (You can set and change conditions without stopping the

production line while it is operating.)

- For details about setting the specific controller model, see page 5-2.

 Adding a new object type
1. Click the [Object type conditions] tag on the parameter list. Then click the right mouse button on the [New

object type]. Next, click on [Add]. (You may double click the left mouse button instead of clicking the right

mouse button.)

- The [Add] dialog box will appear.

2. Select an object type number to add and click on the [OK] button.

- Then new object number will be added.

Click here
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 Setting the measurement conditions: When measurement 0 and camera 1 (position deviation measure-
ment) is selected.

1. Double click on [Measure 0 Camera 1 Conditions].

Double-click here

Double-click here

2. Click on "Measure position deviation" and then click on the [Close] button.

- "Measure position deviation" will be added to the [Measure 0 Camera 1 Conditions] menu.

3. Double click on the "Measure conditions" item on the "Measure position deviation" menu. - See the next

page.

- The "Measure 0 Camera 1 Conditions" dialog box will open. Click on the "Measure position deviation"

item.

Click here
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- The "Measure position deviation" setting screen will appear.
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3-1 Setting the measurement conditions
Select the "Measure position deviation" tab and double-click on the "Measure conditions" item on the

parameter list. The measurement condition screen will appear.

 Operation details: When setting up the positional deviation measurement (2-point search)
Click on the """ button to display the registration condition items on the "Measure position deviation" setting

screen(previous page). Then click on the "2P search" item.

- The measurement condition screen for the "2P search" will appear.

For details about the settings, see the "IV-S30/C35M user’s manual."

Click here
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3-2 Setting the evaluation conditions
Select the "Object type condition" tab and double-click on the "Evaluation conditions" item on the param-

eter list. The evaluation condition screen will appear.

 Operation details: When setting up the positional deviation measurement (2-point search)
Double-click on the "Evaluation conditions" menu on the parameter list.

- The evaluation condition screen for a 2-point search will appear.

For details about the settings, see the "IV-S30/C35M user’s manual, Function and Operation."

Double-click here

The registration number

setting.

MODEL 0 items to set.

MODEL 1 items to set.

Angular deviation

items to set.
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3-3 Setting the numerical calculation conditions
Select the "Object type conditions" tab and double-click on the "Numeric calculation conditions" item on

the parameter list. The numerical calculation screen will appear.

 Operation details: When setting up the positional deviation measurement
Double-click on the "Numeric calculation conditions" menu on the parameter list.

- The "Numeric calculation conditions" screen for measuring positional deviation will appear.

- Enter a calculation result number and click on "Yes" in the "Register" item. Then, you can specify

each setting individually (type, formula, evaluation, and output). (See the next page.)

Double-click here
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Click on each of the individual setting sections 1 to 5 below, on the numerical calculation setting table. The

details for each setting will appear.

1 Object type setting details

2 Setting details for formula 1-1 (When the type is the X ad Y coordinates, x and y deviations, degree of

match M, or angle B)

2 Setting details for formula 1-2 (When the type is a numerical calculation NC)

2 Setting details for formula 1-3 (When the type is a constant C) 3 Setting details for formula 2

4 Setting details for upper & lower limits 5 Setting details for output

For details about these settings, see the section describing the numerical calculation in the "IV-S30/C35M

user’s manual (Function and Operation)."

[Example of settings]

· When angle B is selected,

the model item is not dis-

played.
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Described below is the process used to set the calculation result N0 for the setting example shown on the

previous page.

(1) Setting the object type

1. Enter "0" for the calculation result number and click on "Yes" in the "Register" dialog box.

2. Click on "[X] coordinate."

(2) Setting the formula

1. Enter "0" for the registration number and model number, and click on the "Input" button.

- The setting details for the formula will appear.

2. Click on the "+" button.

- The "+" symbol will be shown on the cell to the right of "00X0."

3. Repeat steps 1 and 2 to enter more formula steps.

Continued on the following page
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From the previous page

(3) Setting the upper & lower limits

Specify the upper limit for evaluating the output.

1. Click inside the upper limit box for the upper limit.

- The current value will be highlighted.

2. Type in the number "410."

(Reference)

You can also set the upper & lower limits by clicking on the '/" buttons.

(4) Set the output.

Specify the upper limit for evaluating the output.

1. Click on "Y."

2. Click on "No."

Click here

Click here

Click here

Click here
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3-4 Setting the output conditions
Select the "object type conditions" tab and double-click on the "Output conditions" item on the parameter

list. The output conditions screen will appear.

 Operation details: When setting up the positional deviation measurement
Double-click on the "Output conditions" menu on the parameter list.

- The "Output conditions" screen for measuring positional deviation will appear.

- Select the page number, and click on the "Yes" item. Then you can specify each setting individually.

For details about these setting, see the "IV-S30/C35M user's manual, Function and Operation: PC

Function."

Input signal
items to set

Logical symbol
items to set

Output signal
items to set

Double-click here
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[Example of settings]

Described below is the process used to create the example above.

1. Enter "0" for the page number, and click on "Yes" in the "Register" item.

2. Click on column 0 on the "INPUT 0" line.

3. Click on "Degree of match M"  as the parameter you want to change.

4. Click on the [–| |–] item in the "LOGICAL SYMBOL." area.

- The selected input signal and logical symbol will be shown.

(Reference)

· Enter the registration number and the model number (0 or 1) by clicking inside the box or on the '/"

arrows (see above `).

5. To create the input section, click on the desired cell, logical symbol, and objective parameter repeat-

edly, the same as in steps 1 to 4 above. (The cursor will automatically move to the right of the specified

column.)

6. Click the output column on the "INPUT0" line.1.

Click here

`(See reference below)

3
4

Click here

Click
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7. Specify the output number for the output signal, and the click on the "Input" (enter) button.

- The output signal and the auxiliary relay C000 will be shown in the table.

(Reference)

- Set the auxiliary relay number (0 to 127) by entering a number of by clicking on the '/" arrows (`1)

on the auxiliary relay box, or click inside of the relay number window (`2) to highlight, then enter the

number directly.

`1

Click here

`2 See reference below
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3-5 Setting the distance and angle conditions
Select the "Object type conditions" tag and double-click on the "Distance and angle conditions" item on

the parameter list. The distance and angle conditions screen will appear.

 Operation details: When setting the positional deviation measurement
1. Double-click on the "Distance and angle conditions" menu on the parameter list.

- The "Distance and angle conditions" screen for measuring positional deviation will appear.

Double-click here
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2. Specify the auxiliary conditions in the "Distance and angle conditions" dialog box.

3. Specify the other conditions.
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Chapter 4: Reading/Writing Parameters and Images

Chapter 4: Reading/Writing Parameters and Images
You can save the parameter settings and images (display images, messages, patterns) stored in an IV-S30/

C35M controller using a personal computer. Parameter settings can also be downloaded into an IV-S30/C35M.

- For details about setting the specific controller model, see page 5-2.

4-1 Read
Reads the parameter settings and images stored in the IV-S30/C35M to a personal computer.

1. Select the "Read" item using the following menu sequence.

"IVS30 communication" → "IVS30 data transfer" → "Read"

- The dialog box for the "Read" session will appear.

2. Click on the "Start" button to start the data transfer.

- If you want to specify or modify the transfer or communication conditions, click on the "Option" button.

(To send the parameters and gray scale images, select the MAIN OPS MENU screen on the IV-S30/

C35M.)

- [Chapter 2: Optional settings]

3. After the transfer is complete, the "Data transfer complete" message box will appear.

- To end the operation, click on the "OK" button.

Click here
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4-2 Write
Write the parameter settings and images stored into a personal computer to the IV-S30/C35M.

1. Select the "Write" item using the following menu sequence.

"IVS30 communication" → "IVS30 data transfer" → "Write"

- The dialog box for the "Write" session will appear.

2. Click on the "Start" button to start the data transfer.

- If you want to specify or modify the transfer or communication conditions, click on the "Option" button.

- [Chapter 2: Optional settings]

3. After the transfer is complete, the "Data transfer complete" message box will appear.

- To end the operation, click on the "OK" button.

Click here
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4-3 Verify
Verify that the parameter settings and images are the same in the personal computer and the IV-S30/

C35M.

1. Select the "Verify" item using the following menu sequence.

"IVS30 communication" → "IVS30 data transfer" → "Verify"

- The dialog box for the "Verify" session will appear.

2. Click on the "Start" button to start the data transfer.

- If you want to specify or modify the transfer or communication conditions, click on the "Option" button.

- [Chapter 2: Optional settings]

3. After the transfer is complete, the "Data transfer complete" message box will appear.

- To end the operation, click on the "OK" button.

Click here
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4-4 Initialization
Initialize all parameters in the IV-S30/C35M.

1. Select the "Initialize" item using the following menu sequence.

"IVS30 communication" → "IVS30 data transfer" → "Initialize"

- The dialog box for the "Initialize" will appear.

2. Click on the "Start" button to start the data transfer.

- If you want to specify or modify the transfer or communication conditions, click on the "Option" button.

- [Chapter 2: Optional settings]

3. After the transfer is complete, the "Data transfer complete" message box will appear.

- To end the operation, click on the "OK" button.

Click here
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4-5 Self diagnosis
Start the self-diagnosis function in the IV-S30/C35M.

1. Select the "Self test" item using the following menu sequence.

"IVS30 communication" → "IVS30 data transfer" → "Self test"

- The dialog box for the "Self test" will appear.

2. Click on the "Start" button to start the self-diagnosis.

- If you want to specify or modify the transfer or communication conditions, click on the "Option" button.

- [Chapter 2: Optional settings]

3. After the transfer is complete, the "Data transfer complete" message box will appear.

- To end the operation, click on the "OK" button.

Click here
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Chapter 5: File operations
Save the IV-S30/C35M's parameter settings and images in a file or load the same type of stored data back into

the IV-S30SP.

The "File" menu shown below is used by all the parts of this program.

Ë New

Start a new file from the IV-S30SP parameter. All of the parameters will be set to their default values.

- Select the "New" item from the "File" menu.

Ë Open

You can open the types of files listed below.

- Select the "Open" item from the "File" menu.

- The "Open" dialog box will appear.

Ë Save the currently displayed image

Save the image that is currently open on the IV-S30SP.

- Select the "Save display image" item from the "File" menu.

- The "Save display image" dialog box will appear.

Ë Open project

Open a project file (*.apm).

- Select the "Open project" item from the "File" menu.

Ë Save project

Save all of the files currently open, which have any of  the extensions described in the "Open" file section.

The files, including all of the data, are seved in a project file (*.apm).

- Select the "Save project" item from the "File" menu.

snoisnetxeeliF sliateD

pmb.* segamiecnereferdnayalpsidehtfoelifpamtiB

rsm.* snoitidnocgnittesepyttcejbO

mrp.* snoitidnoclabolG
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Ë Save As project

Save all of the files currently open, which have any of  the extensions described in the "Open" file section.

The files, including all of the data, are saved in a new project file (*.apm). The data is stored under the new

name.

- Select the "Save As project" item from the "File" menu.

Ë Close project

Close the project files (*.apm).

- Select the "Close project" item from the "File" menu.

Ë Property

Select the controller type you are using and enter a project name.

1. Click on the [Properties] item on the [File] menu.

2. The [Properties] dialog box will appear.

*1

*2

*1: When the IV-S31M/S32M software version is V1.**.

*2: When the IV-S31M/S32M software version is V2.**.

- When the controller type is changed, the software will automatically change the project’s parameters.

Note: A project file is a file used to manage all of the various types of parameters in the IV-S30/C35M.

Click here
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Click here

Continued on the following page

Chapter 6: Document Creation
You can automatically create a spreadsheet (table of the current parameters) using Excel or other standard

applications, so that you can easily manage and store parameter sets as documents.

6-1 Document creation (Project file)
This section describes the procedures for creating a document that contains the parameters in a per-

sonal computer file.

(1) Setting/operating the IV-S30/C35M

Bring up the MAIN OPS MENU screen on the IV-S30/C35M.

(2) Communication setting

Set the parameters for communicating with the IV-S30/C35M.

- See "Chapter 2: Optional settings."

(3) Loading the parameters

1. Click the "Create document" item on the "Tools" menu.

- The "Create document" dialog box will appear.
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(4) Create a document from a project file.

Click on the "Open project file" item in the "File" menu.

- The dialog box for "Open project file" will appear.

(5) Select a file

Select the project file that you want to create a document from in the "Create document" dialog box

(project file extension: *.apm).

(6) Document creation details

Check the boxes next to all of the conditions you want to use in creating the document. Then, click on the

"Create document" menu.

- The dialog box for saving the file will appear. Enter the new document file name (document creation

file extension: *.csv).

Click here



6-3

Chapter 6: Document Creation

6

IV
-S

30
/C

35
M

6-2 Document creation (IV-S30/C35M parameter loading)
This section describes the procedures for creating a document from the parameters already in the IV-

S30/C35M.

(1) Select a file in which to save the parameter settings

Click on "Read parameters" on the "IV-S30 data Transfer" menu.

- The "Read parameters" dialog box will appear.

(2) Start data transmission

Click on the "Start" button to start the data transmission.

* If you want to specify or change the communication settings, select the "Communication setting" item in

the "IVS30 data Transfer" menu, or click on the "Set Comm" button in the "Read parameters" dialog

box.

Click here

Click here

* Click here
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[Example of document creation]

Shown below is an example file document (with ".csv" extension) that contains conditions for each

object type and can be opened using Excel.

<<< Object type number 00 >>>
TITLE� SAMPLE
---- Main ----
MEAS.0, CAMERA 1� POSITIONAL DEVIATION MEASUREMENT
MEAS.0, CAMERA 2� NO
MEAS.1� NO
MEAS.2� NO
MEAS.3� NO
HALT MEAS ON NG� NO
POS. ADJ.CAMERA 1� NO CALIBRATION
POS. ADJ.CAMERA 2� NO CALIBRATION

---- Positional deviation measurement (Camera 1) ----
[MEAS. PROG. COND]
* Registration number�� 0
Mode� 2 point search
<First point>
MEAS WINDOW� RECTANGLE
REF IMAGE upper left X COORD�� 68
REF IMAGE upper left Y COORD�� 232
REF IMAGE lower right X COORD�� 139
REF IMAGE lower right Y COORD�� 295
SEARCH AREA upper left COORD�� 60
SEARCH AREA upper left COORD�� 224
SEARCH AREA lower right COORD�� 147
SEARCH AREA lower right COORD�� 303
DTECT COORD�  CNTR
DTECT COORD (X)�� 104
DTECT COORD (Y)�� 264
CONTR. PIXEL�� 3
<Second point>  
MEAS WINDOW� RECTANGLE
REF IMAGE upper left X COORD�� 356
REF IMAGE upper left Y COORD�� 232
REF IMAGE lower right X COORD�� 427
REF IMAGE lower right Y COORD�� 295
SEARCH AREA upper left COORD�� 348
SEARCH AREA upper left COORD�� 224
SEARCH AREA lower right COORD�� 435
SEARCH AREA lower right COORD�� 303
DTECT COORD�  CNTR
DTECT COORD (X)�� 392
DTECT COORD (Y)�� 264
CONTR. PIXEL��  3
DETECT ACCURACY� STANDARD
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[OBJECT TYPE I/O]
1TRIG CCD START� NO YES(BIN  AVG-GRAYS  GRAY-SRC)
2CCD TRIG COND� (TO NEXT SUB-MENU) 
2CCD TRIG COND� (TO NEXT SUB-MENU) 
3SHUTTER SPEED� 1/00060(1/30～1/10000)
4SERIAL OUTPUT� ANY  BLOCK-ASSIGN
5SET SERIAL BLOCK BLOCK00 MEAS0 CAM1

OPS-MENU  RETURN  LOCK

OPS-MENU  SAVE  LOCK  TITLE  FINAL-CALC  FINAL-OUTPUT  I/O  SYSTEM

[TYPE MEAS COND]
1OBJECT TYPE NO.�00(0~63)  NO  YES

On the "MAIN OPS MENU," move the cursor to MEA-CND and press the SET key.

- On the [TYPE MEAS COND] menu, move the cursor to [I/O] and press the SET key. 

2

2. Assign block numbers to be used to collect data on the "SET SERIAL BLOCK" line.

Chapter 7: Data Collection (Measurement result/NG image)

You can transmit the measurement result/NG image result data from the IV-S30/C35M to a personal computer
via communication cable (general purpose serial I/F), and automatically create a result sheet.
The data collection function is used to manage or save measurement data, and collect data settings such as
the evaluation conditions.

- For details about setting the specific controller model, see page 5-2.

This chapter explains the procedures for data collection.

(1) Setting/operation of the controller

1. Select "BLOCK-ASSIGN" on the "SERIAL OUTPUT" line of the [OBJ-TYPE I/O] menu.

 When using the IV-S31MX/S32MX/S33MX, IV-S30J, or IV-C35M

 When using the IV-S31M/S32M/S33M

OBJ-TYPE I/O　　SCREEN　SAVE

1TRIG CCD START� NO

2SHUTTER SPEED� I/00060(I/30～I/10000) 
3SERIAL OUTPUT BLOCK-ASSIGN  
4SET SERIAL BLOCK BLOCK00 MEAS0 CAM1
5CALIBRATION      � (TO NEXT SUB-MENU)

BLOCK-ASSIGN
ANY

2
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3. Set the "SERIAL OUTPUT" or "OUT I/F (PARAL.)" item on the [I/O CONDITIONS] menu. The settings

will depend on the type of controller you are using.

 When using the IV-S31MX/S32MX/S33MX, IV-S30J, or IV-C35M

Select "No."

 When using the IV-S31M/S32M/S33M

The settings will depend on the type of controller (software version) you are using.

NO 
PC-LINK 
SERIAL

1MEAS INP I/F� PARALLEL + SERIAL + USB 
 
2OUT I/F(PARAL.)� NO�

3MANL TYPE CHNG� NO�

4PARALLEL INP X6� EXT-INP�
 
5PARALLEL INP X7� EXT-INP�
6STROBE� NO�
7'READY' ON CAPTURE COMPLETE

I/O CONDITION� SCREEN  COND  SAVE

[SYSTEM COND]

1I/O CONDITIONS� (TO NEXT SUB-MENU)
2COMM. SET� (TO NEXT SUB-MENU)

[I/O CONDITIONS]
1MEAS INP I/F� PARALLEL+SERIAL+USB  CCD-TRIG

2SERIAL OUTPUT� NO   PC-LINK  SERIAL 
3MANL TYPE CHNG� NO  YES
4PARALLEL  INP X6� 64OBJ-CHG REG REF(MEAS0 COMPARE-IMGS)
� MODIFY-AREA-SIZE(00%) EXT-INP
5PARALLEL  INP  X7� EXT-INP  CHNG-IMG-OUT-CAM  CAM-MEAS  2  IMAGES 
6STROBE OUT� NO   Y0
7’READY’ ON� CAPTURE COMPLETE MEAS-COMPLETE

OPS-MENU  RETURN  LOCK

On the "MAIN OPS MENU," move the cursor to [SYS-CND] and press the SET key.

- On the [SYSTEM COND] menu, move the cursor to "1I/O CONDITIONS" and press 

   the SET key. 

*1

*2

*1: When the IV-S33M, IV-S31M/S32M (software version V2.01 or later) is used. - Select "NO."
*2: When the IV-S31M/S32M (software version V1.15 or before) is used. - Select "SERIAL."

4. Return the  IV-S30/C35M screen to the "MAIN OPS MENU."

Continued on the following page
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Click here

Click here

Continued on the following page

Click here
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(2) Starting the data collection screen

Click on the "Data collection" item in the "Tools" menu.

- The "Data collection" dialog box will appear.

(3) Communication settings

Specify the communication settings by selecting the "Communication setting" item in the "Setting" menu

on the IV-S30SP program and communication setting of the IV-S30/C35M.

(4) Sampling setting

1. Click on the [Sampling setting] item on the [Setting] menu.

- The [Sampling setting] dialog box will appear.

2. Set the sampling data, number of samples, and data processing required in the screen below, accord-

ing to your use and application.

The number of samples and data processing
settings affect the "measurement result data"
obtained from the sampling data.

"NG image data" can be selected
when "USB" is selected for the
communication method (see above).
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[Sampling data]

- Measurement result data: Collect the results from the data measured.

- NG image data: Collect NG images.

(In order to collect NG images, select "YES" for NG image registration on the "OB-

JECT TYPE SYS." menu on the controller (except IV-S31M/S31MX.))

[Number of sampling]

Enter the number of samplings and method here.

- 1000: Collect up to 1000 sets of data

- 5000: Collect up to 5000 sets of data

- Unlimited: Save data on a hard disk (the sampling speed will be slower).

[Data processing]

Set the data processing method for the data samples.

- Count the number of samples in each set of measurement data: Total the number of data samples in

each set of measurement data, and output the total and number of samples.

- Sort in measurement order: Output the measurement results in same order that the samples were

taken.

(5) Setting the data collection conditions

1. Click on the "Setup" button.

- Load the IV-S30/C35M parameters and display the data collection conditions that can be specified.

2. Select the items for data collection.
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Click here

1

2
1. Click on the "Cancel" button.

- The data collection will stop.

2. Click on the "Create a data list" button.

 - When the [Open] dialog box appears, select the directory position and assign a file name in which to

save the data.

- The data summary file will be created automatically.

- The file extension used for the measurement data is "csv" and NG image data is saved as "bmp"

files.

Note

- If processing speed of a personal computer is slower than the data transmission speed of the IV-

S30/C35M, some parts of the data may be lost.

- Displaying the real time chart will reduce the IV-S30SP program's processing speed.

From the previous page

(6) Execute a data collection

Click on the "Start" button.

- Now the IV-S30SP is ready to load data.

(7) Create a summary table of the measurement data, collect NG image data
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25000
25200
25400
25600
25800
26000
26200
26400
26600
26800
27000
27200
27400
27600
27800
28000
28200
28400
28600
28800
29000
29200
29400
29600
29800
30000
30200
30400
30600
30800
31000

0
1
1
2
1
5

13
38
40
12
2
1
0
1
0
1
1
5

14
33
43
39
31
18
2
5
3
1
0
0
0

Create a table using Excel.

Create a graph using Excel.

Data file (with �.csv� extension)
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[Data collection example]
Shown below is an example in which the graph creation feature in Excel is used to make a graph of the

measured data file (with ".csv" extension) created with the data collection function.

Example: Measuring an area by binary conversion, and setting the upper and lower limits for the evalu-

ation conditions of the surface area.
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Chapter 8: User Menu Editor

This function lets you create and modify the MAIN OPS MENU screen and all of the other user menus on the IV-

S31M/S32M/S33M. You can also change the text and titles displayed on those screens.

- For details about setting the specific controller model, see page 5-2.

8-1 How to start the editor
1. Click on the "User menu editor" item on the "Tools" menu.

- The user menu editing screen will appear.

Click here
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8-2 Read
Read in the menu you want to edit, or select the MAIN OPS MENU screen, from the IV-S33M etc.

1. Click on the "Data Transfer" item in the "File" menu.

- The "Data transfer" screen will appear.

2. Select "Read" in the "Data transfer condition" area and check the boxes next to the items you want to

read in the "Items to transfer" area. Click on the "Start" button to read the data from the IV-S33M etc.

8-3 Write
Write new or modified menus, or the MAIN OPS MENU screen, back into the IV-S33M etc.

1. Click on the "Data Transfer" item from the "File" menu (see "8-2 Read").

- The "Data transfer" screen will appear.

2. Select "Write" in the "Data transfer condition" area. In the "Items to transfer" area, check all of the

boxes next to the items you want to send back to the IV-S30. Click on the "Start" button to write the

data back into the IV-S33M etc.

Click here
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8-4 Initialize the user menus
1. Click on the "Data Transfer" item in the "File" menu (see "8-2 Read").

- The "Data transfer" screen will appear.

2. Select "Initialize user menu" in the "Data transfer condition" area. Click on the "Start" button to initialize

the user menus in the IV-S33M etc.
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8-5 Editing Titles
The word "title" refers to the "MEAS SHAPE (MDL0)" text shown inside the rectangle, in the example

below.

MEAS SHAPE (MDL0)   RECTANGLE  X-LINE  Y-LINE

1. Change the title.

Click on the "Title" tab to display the title list. Double-click on the title you want to change.

- The "Modify character strings" dialog box will appear.

2. Change or delete the characters directly in the dialog box, and then click on the "OK" button. The title

will be changed.

Ë To search for a title you want to change

1. Select the "Find" item from the "Edit" menu. (You can also select the "Find" item from the pop up

menu, by clicking the right mouse button when the cursor is over any title.)

Click here
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- The "Find Title list" dialog box will appear.

2. Enter the phrase you want to find. Then click on the "Execute" button to start the search.

8-6 Editing character strings
"Character strings" refers to the words which come after the title, such as "RECTANGLE," "VER-LINE,"

and "HORI-LINE" shown inside the rectangles in the example below.

MEAS SHAPE (MDL0)   RECTANGLE    X-LINE    Y-LINE

1. To change a character string.

Click on the "Character string" tab to display the character string list. Double-click on the text you want

to change.

- For details about changing, deleting, and searching for text, see section, "8-5 Editing Titles."
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8-7 Menu editing
"Character strings" refers to any part of the complete line of text in the example below.

 MEAS SHAPE (MDL0)  RECTANGLE  X-LINE  Y-LINE

Ë To change the title or any of the text which comes after it in the menu

1. Select the menu item in the menu list. The title and character string will be displayed in the menu

details list.

2. Double-click on the title or character string in the menu details list that you want to change. The "Modify

character strings" dialog box will appear.

For details about changing, deleting, and searching for text, see section, "8-5 Editing Titles."
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8-8 Create a user menu
1. Click on the "Create user menu" item in the "File" menu.

- The table for creating a user menu will appear.

2. Select the menu that you want to assign as a user menu from the menu list. To add the item, drag and

drop it onto the menu table.

Click here
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8-9 Create a new MAIN OPS MENU screen
1. Click on the "Create MAIN OPS MENU menu" item from the "File" menu.

- The table for creating a MAIN OPS MENU screen will appear.

2. To add a new user menu, select the "Create user menu" item from the "File" menu. The table for

creating a new menu will appear.

- You can create up to two screens for the IV-S31M, and eight screens for the IV-S32M/S33M.

Click here
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3. Select the area that you want to assign to the MAIN OPS MENU screen from the area list. To add the

item, drag it to the MAIN OPS MENU table. You can change the display position once it is in the table.

8-10 File operation
Ë Create a new file

All the data on the menu editor will be initialized.

- Select the "New" item from the "File" menu.

Ë Open a file

Open a saved file.

- Select the "Open" item in the "File" menu.

File extensions
*. str
*. ume
*. urm
*. fnt

Details
Title and character string data
User menu data
MAIN OPS MENU data
User font data
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Continued on the following page

Click here

Chapter 9: Command Test
The command test function is used to communicate to the IV-S30/C35M through the serial or USB interface

and confirm that communication has been established when the personal computer is started.

This chapter describes the command test procedures.

(1) Setting/operating of IV-S30/C35M

1. Set the "SERIAL OUTPUT" item in the "I/O CONDITIONS" menu of the IV-S30/C35M to "SERIAL."

2. Bring up the MAIN OPS MENU screen on the IV-S30/C35M.

(2) Communication settings

Set the protocols for communication with the IV-S30/C35M.

- See "Chapter 2: Optional Settings."

(3) Starting the command test screen

Click on the "Command Test" item on the "Tools" menu.

- The "Command test" dialog box will appear.

[SYSTEM COND]
1I/O CONDITIONS� (TO NEXT SUB-MENU)
2COMM. SET� (TO NEXT SUB-MENU)

[I/O CONDITIONS]
1MEAS INP I/F PARALLEL+SERIAL+USB  CCD-TRIG 
 
2SERIAL OUTPUT NO   PC-LINK  SERIAL  
3MANL TYPE CHNG NO  YES 
 

NO 
PC-LINK 
SERIAL

1MEAS INP I/F� PARALLEL + SERIAL + USB 
 
2OUT I/F(PARAL.) SERIAL 
3MANL TYPE CHNG� NO
4PARALLEL INP X6� EXT-INP 
 
5PARALLEL INP X7� EXT-INP
6STROBE� NO
7'READY' ON CAPTURE COMPLETE

I/O CONDITION� SCREEN  COND  SAVE

● When using the IV-S31MX/S32MX/S33MX, IV-S30J, IV-C35M

● When using the IV-S31M/S32M/S33M
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From the previous page

(4) Setting the conditions for the command test

In  the "Command test" dialog box, set the conditions for the command test (set the time out, checksum,

and number of repeats).

- The "O" indicates the default setting.

(5) Transmitting serial command

Enter the data to send in the "Command test" dialog box, and press the "Send" button.

- The data will be transmitted to the IV-S30/C35M. The response data will be displayed in the receive

data area.

Continued on the following page
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Enter the
data to send

Display the
data re-
ceived

Checksum
values

Click here



Chapter 9: Command Test

9-3

119

IV
-S

30
/C

35
M

From the previous page

(6) Saving files

- Saving the data received to a file

1. Click on the "Open"  item in the "File" menu.

- The "Open"  dialog box will appear.

- When you want to create a new file (with the ".tst" extension) to save the data received, specify

the folder name, enter the file name, and click on the "Open" button.

If you want to save it to an existing file, select the file and click on the "Open" button.

2. Click on the "Save"  item in the "File" menu.
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Continued on the following page

Set key (SET)
Left key (\)

"XX" will vary  depending on the models, and "YYY" will vary

depending on the versions.

Chapter 10: Upgrade Version
To upgrade the IV-S30/C35M system version (improved functions) you simply download the new version from

a personal computer.

- The IV-S30/C35M software consists of the "system program," used to set up and execute image processing

operations, and a "boot program" to load the other programs.

In some cases, both programs need to be upgraded. (Refer to our sales department for the latest version of

the system software.)

Described below are the procedures for upgrading the program version.

(1) Preparation

Create the folders below for installing the software.

SXXYYY.mot system program

BXXYYY.mot boot program

(2) Communication settings

Set the protocols for communication with the IV-S30/C35M.

- See "Chapter 2: Optional settings."

(3) Setting/operating of IV-S30/C35M

1. Turn on the IV-S30/C35M.

- Turn on the controller IV-S30/C35M, while pressing and holding down both the left key (\) and the

set key (SET) on the remote key pad at the same time.

- The IV-S30/C35M upgrade version menu (IV**** VERSION UPGRADE MENU) will appear on the

monitor.

[IV-S3*** VERSION UPGRADE MENU]
1IVS3*** SYSTEM RECEIVE (USB) RUN
2IVS3*** SYSTEM RECEIVE (RS232C) RUN
3BOOT RECEIVE (USB) RUN
4BOOT RECEIVE (RS232C) RUN
5RS232C BAUDRATE 115.K bps 19.2K bps
6ALL INITIALIZE RUN
7POWER ON RESET RUN

2. Select the upgrade version menu.

- Move the up and down keys to select the "1 IV-S3*** SYSTEM RECEIVE (USB)" item and press

the set key (SET).

(The "3 BOOT RECEIVE (USB)" item may also be needed to perform the upgrade, depending

on the upgrade conditions.)

(When an IV-S3*** is used)
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(4) File selection
Click on the "Version upgrade" item on the "IVS30 communication" menu.

- The "Open" dialog box will appear.
- Select the (SXXYYY.mot) file and click on the "Open" button.

(5) Transmission

The "Version upgrade" screen will appear.

- Click on the "Option" button. Specify the communication and upgrade conditions.
(See pages 2-1, 2-2, and 2-4.)

Click on the "Start" button to start the data transmission. (To stop the transmission, click on the
"Cancel" button.)
- When the [  ON RECEIVE ] message appears on the IV-S30/C35M monitor and the [  ] flashes,

the transmission has been successful.
- It takes approximately 20 seconds to transmit the complete file through the USB interface. (Note:

When an RS-232C interface is used, it will take approximately 10 minutes with a Pentium 266 MHz
personal computer.)

- When the [  ON RECEIVE ] display disappears, the new system program has been successfully
written to the flash memory.

(6) Starting the new version of the system

Move the up and down keys to select "7 POWER ON RESET" on the IV-S30/C35M upgrade version

menu (displayed on the monitor) and press the [SET] key.

[IV-S3*** VERSION UP MENU]
1IVS3*** SYSTEM RECEIVE (USB) RUN
2IVS3*** SYSTEM RECEIVE (RS232C) RUN
3BOOT RECEIVE (USB) RUN
4BOOT RECEIVE (RS232C) RUN
5RS232C BAUDRATE 115.K bps 19.2K bps
6ALL INITIALIZE RUN
7POWER ON RESET RUN

- The power to the IV-S30/C35M will be reset and the new version of the system program will start.

Click here

Click here

(When an IV-S3*** is used)
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Chapter 11: Additional Descriptions
This chapter describes other functions such as Printing, Changing the Message Display Color, Changing the

Image Brightness, Accessing the SMS Web page and Memory card (IV-C35M).

[1] Print
Images displayed on the IV-S30SP monitor can be printed.

(Printing procedure)

1. Click on the "Print" item in the "File" menu.

[2] Changing the message display color
You can select oen of 8 colors for the display image color. If the image and the message are same colors,

use different message color to allow you to see the message.

- The colors you can chose from are black, blue, green, cyan, red, magenta, yellow, and white.

(Operation procedures)

1. Move the cursor to "Message color" on the "View" menu.

2. Select a color.

Select the desired color. (Default: black)

- The message color will be changed.

Click here
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[3] Zoom
You can change the display magnification of the image by changing the zoom setting.

(Zoom setting)

1. Select the "Zoom magnification rate" item in the "View" menu.

2. Select a rate.

Click on the level of magnification you want. (Default: 100%)

- The zoom setting will be changed.

[4] Changing the image brightness
You can set the displayed image brightness to "Standard" or "1/2."

(Operation procedures)

1. Move the cursor to the "Display image Bright level" item on the "View" menu.

2. Select a brightness.

- Click on "Standard" or "1/2." (Default: Standard)

- The displayed image will be changed to the selected brightness.
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[5] SMS Web page
If your personal computer is ready to connect to the Internet, the default Web browser will be started and

automatically connect you to the Sharp Manufacturing Systems Corporation Web site.

(The URL address is listed on the back cover of this manual.)

(Connecting to the Sharp web site)

1. Select the "SMS Web page" item in the "Help" menu.
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[6] Memory card (IV-C35M)
When the IV-C35M is used, you can read, save, or delete data from a flash memory card (max. 192 MB)

using the IV-S30SP.

(Operation procedures)

1.Select the "Memory card" on the "Tools" popup menu.

2. Select any operation, such as "Read", on the "Memory card" popup menu.

- A dialog box will open for the selected operation.

3. Specify file type (parameter or NG image) and select the drive, directory, and file on the flash memory

card. Then click on the [OK] button.

- The specified operation will be executed.

(When reading data)
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Chapter 1: Menu Organization
After starting this software (for the IV-S20), the screen shown below will appear. The menu organization on the

menu bar is also shown below.

The following menus (1) to (7) correspond to the items from the next page.

- This screen will be displayed when this software (for the IV-S20) is started.

(1) (2) (3) (4) (5) (6) (7)
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(1) File

(2) Edit

Open an existing image file. (*.bmp)

(Description)

Create a new file.New� Ctrl + N

Open image� Ctrl+O

Save

Image only

Messages only

Image + Message

Save the display images only.

Save both the images and messages.

Save messages only.

Read the display image (camera 1) from the IV-S20.

Read the display image (camera 2) from the IV-S20.

Read messages from the IV-S20.

Read image

Display image (Camera 1)

Display image (Camera 2)

Display image (Camera 1)

Display image (Camera 2)

Message

Write image

Set Communication

Command Test

Print� Ctrl+P

Select printer type

Exit� Ctrl+Q

Write the display image to the IV-S20.

Write the display image to the IV-S20.

Set the communication conditions of the IV-S20SP.

Send any serial command to the IV-S20.

Set up a printer.

Print

Quit the IV-S20SP.

Black, Blue, Green, Cyan,
Red, Magenta, Yellow, 
and White

Delete the images displayed on the IV-S20SP.

(Description)

Change the message display color to the specified color.

Delete display image

DISP image bright level

Normal

Half

Copy display image

Message color

Image only

Messages only

Image + Message

Set the display image brightness to normal.

Decrease the display images brightness to half level.

Copy the images only to the clipboard.

Copy messages only to the clipboard.

Copy both the image and messages to the clipboard.
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File - Set screen

Select an IV-S20 setting data file to treat.

(Description)

Load

Save

Load the setting parameters from the file to the IV-S20.

Load the setting parameters from the file to the set screen.

Load the setting parameters from the set screen to the IV-S20.

File - IV

Set screen - IV

IV - File

Select a file

Set screen - File

IV - Set screen

Verify

Initialize

Self diagnosis IVS20

Creates a document

Data collection

File =- IV 

File =- Set screen

IV =- Set screen

Save the setting parameters from the IV-S20 to the file.

Save the setting parameters from the set screen to the file.

Save the setting parameters from the IV-S20 to the set screen.

Verify the file with the IV-S20 setting parameters.

Verify the file with the set screen setting parameters.

Verify the IV-S20 data and the set screen setting parameters.

Initialize the IV-S20.

Initialize the set screen.

Self diagnose the IV-S20.

Automatically create the setting data document.

Save the measurement result data from the IV-S20.

IV-S20

Set screen

(3) IV data settings
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(4) Object type COND

(Description)

Object type NO. (0 - 15) Set and change object type number.

Title registration Set a title to each object.

MEAS.0 Camera 1

MEAS-POSITION-DEVIATE

MEAS-POSITION-DEVIATE

Set and change each condition of positional 
deviation measurement (Camera 1).

Set and change each condition of positional 
deviation measurement (Camera 2).

POS.ADJ. Camera 1 Set and change position adjust condition.

MEAS.0 Camera 2

POS.ADJ. Camera 2

Measurement 1

CHECK-DEG-OF-MATCH

INSPECT-LEADS

DIST/ANGLE 
(GRAY/EDGE)

DIST/ANGLE (C-GRAV)

MEASR-BIN-AREA

COUNT-BIN-OBJ

LABEL-BIN-OBJ

MEASURE POINTS

Set and change various conditions of distance and angle 
measurement (Gravity center).

Set and change various conditions of distance and angle 
measurement (gray and edge).

Set and change various conditions of lead inspection.

Set and change various conditions of area measurement 
by binary conversion.
Set and change various conditions of counting quantities 
by binary conversion.

Set and change various conditions of label measurement 
by binary conversion.

Set and change various conditions of point measurement.

Measurement 2

(Same as Measurement 1)

Measurement 3

(Same as Measurement 1)

FINAL NUMERIC CALC

FINAL OUTPUT COND

SYSTEM-IN/OUT

HALT MEAS ON NG

 NO

 YES

Set and change various conditions of final calculation result.

Set and change various conditions of final output condition.
Set and change various conditions of system-In/Out for 
each object style.

Continues measurements even if a NG evaluation occurs.

Halt all measurement if a NG evaluation occurs.

Set and change various conditions of degree of match 
inspection.



1-5

Chapter 1: Menu Organization

1

IV
-S

20

(5) Version up

(6) Window

(7) Help

(Description)

Select a file

Transfer data Without INIT

Transfer data and INIT All data

Select a file to meet version of the IV-S20.

After data transmission, upgrades the version without 
initialization.
After data transmission, upgrades the version with ini-
tializing measuring conditions.
After data transmission, upgrades the version with ini-
tializing all.

Transfer data and INIT 
MEAS COND

(Description)

All object type list display Display conditions of all object types on the setting screen.

Monitor display image Change between display or not display the display image.

Option

Object type display Display conditions of one object type on the setting screen.

Tool bar

Status bar

Cascade display

Tile Vertically

Tile Horizontally

Change between display or not display the tool bar.

Change between display or not display the status bar.

Overlap the open windows.

Display the open windows in a vertical layout.

Display the open windows in a horizontal layout.

(Description)

Search topic

About program information

Display the help menu search topic screen.

Display the version information for the IV-S20SP program.
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Chapter 2: Set Communication
When you communicate between the PC and the IV-S20, you must specify the "Set communication."

Ë Communication menu items

Display items for communication between the PC and the IV-S20.

Ë Operation of the communication settings

1. Click "Set Communication" on the "File" menu.

- The "Set communication" dialog box will appear.

2. Select the port number, and then click the "SET" button.

- Set the personal computer’s communication port.

Setting items other than the "Port" can be operated with the default setting (set at delivery).

Setting items
Default
setting

Number of bits
Parity
Stop bits
Port

115.2 kbps

7
Even

2
1

Communication 
speed

Click

Click

Select the commu-
nication port

File

Read
image

Write
image

Display image (Camera 1)

Display image (Camera 2)

Display image (Camera 1)

Display image (Camera 2)

Message

Load

Save

Verify

Initialize

Self diagnosis IVS20

Data collection

File - IV

Set screen - IV

IV - File

File =- IV

IV-S20

IV =- Set screen

IV - Set screen

IV data settings Version up

Transfer data Without INIT

Transfer data and INIT MEAS
COND

Transfer data and INIT All data
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Chapter 3: Setting Object Type Conditions
Set object type conditions (Measurement conditions, Evaluation conditions, Numerical conditions, and output

conditions) by clicking each item from the "Object type COND" menu.

- You can set and change the conditions offline. (You can set and change without stopping the line while the

production line while it is operating.)

- For details about the setting details, see the "IV-S20 user’s manual."

Ë "Object type COND" menu

- "MEAS. 0 Camera 2" is the same operation.

- Measurement 2, Measurement 3, are the same operation.

Click the item. Each setting screen will appear.

Ë Operation details: When setting up the positional deviation measurement

Click the "MEAS. 0 Camera 1" or "MEAS .0 Camera 2" from the "Object type COND" menu, then select the

"MEAS-POSITION-DEVIATE."

- The positional deviation measurement setting screen will appear.

Click
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Edge detection
conditions set-
ting items.

3-1 Setting the measurement conditions
Click each measuring program from the "Object type COND" menu. The "MEASUREMENT CONDI-

TIONS" screen will appear.

Ë Operation details: When setting up the positional deviation measurement (1-point search + 1-point edge)

1. Click the "YES" button on the "REG." on the position deviation measurement setting screen (previous

screen.)

- The setting screen for the "1P-SCH" (1-point search) will appear.

2. Click the """ of the "MODE", then select the "1P-SCH + 1P-EDGE."

-  The "MEASUREMENT CONDITIONS" screen for the "1P-SCH + 1P-EDGE" will appear.

For details about the settings, see the "IV-S20 user’s manual."

Click

Click

Gray search
conditions set-
ting items.
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3-2 Setting the evaluation conditions
Click the "EVALUATION CONDITION" from each measuring program setting screen. The "EVALUA-

TION CONDITION" screen will appear.

Ë Operation details: When setting up the positional deviation measurement (1 point search + 1 point edge)

Click the "EVALUATION CONDITION" in the positional deviation measurement setting screen (previous

screen.)

- The "EVALUATION CONDITION" screen for the "1P-SCH + 1P-EDGE" will appear.

For details about the settings, see the "IV-S20 user’s manual."

The registration number setting items.

MODEL 0 setting items.

MODEL 1 setting items.

Angular deviation setting items.

Click
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Click

3-3 Setting the numerical calculation conditions
Click the "NUMERIC CALC. COND" from each measuring program setting screen. The "NUMERIC

CALC. COND" screen will appear.

Ë Operation details: When setting up the positional deviation measurement

Click the "NUMERIC CALC. COND" on the position deviation measurement setting screen (page 3-2).

- The "NUMERIC CALC. COND" screen for positional deviation measurement will appear.

- Click each setting section (object type, upper&lower limit, output, and formula) for numerical calculation.

The each setting detail will appear. (See the next page.)

The setting table
for numerical
calculation (N00
to N15.)

Display each
setting detail.



3-5

3

Chapter 3: Setting Object Type Conditions

IV
-S

20

Click on each of the individual setting sections 1 to 5 below, on the numerical calculation setting table.

The details of each setting will appear.

1 Object type setting details

2 Setting details for upper & lower limit 3 Setting details for output

4 Setting details for formula 1-1 (When the type is X and Y coordinates, x and y positional

deviation coordinates, and degree of match M, or angular deviation B)

4 Setting details for formula 1-1 (When the type is a numerical calculation NC)

4 Setting details for formula 1-1
     (When the type is a Constant C)

1 2 3 4 5 4 5

For details about these setting details, see the "IV-S20 user’s manual: Chapter 9: Numerical Calculations."

[Example of settings]

The setting process of the calculation result N01 is described on the next page.

· When angular deviation B

is selected, the model item

is not displayed.

5 Setting details for formula 2
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Described below is the process used to set the calculation result N01 for the setting example shown on the

previous page.

(1) Setting the object type

1. Click the "TYPE" cell N01.

- The setting details for object type will appear.

2. Click the "COORD [X]."

- The [X] will be indicated on the "TYPE" cell N01.

(2) Setting the formula

1. Click the "FRMLA" cell N01.

- The setting details for formula 1 will appear.

2. Click the "REG." item.

- A "0X0" will be indicated.

3. Click the right cell of the "0X0."

- The setting detail for formula 2 will appear.

4. Click the [*] item.

- The "*" will be indicated on the right cell of the "0X0."

5. Click the right cell of "*", then click the "N" item in the setting detail for formula 1.

- The "N0" will be indicated on the right cell of the "*."

Click

Click

Click A number "00000002.0" will appear by

clicking the "N00" cell on the left side.

Click

Click

Click

Continued on the following page
Displayed
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Click here

From the previous page

Double-click here

Indicated

1 Click the " item to select the

number of digits.

2 Click the '/" item of the upper & lower limit.

Click

Displayed

From the previous page

(3) Setting the upper & lower limits

1. Click the "LOW-LMT" (lower limit) or "UP-LMT" (upper limit) cell on the "N01" line.

- The setting detail for the upper limit or lower limit will appear.

2. Double-click the inside of the upper limit item.

- The display will be highlighted.

3. Type in the number "410", then press the "Enter" key.

- The number "00000410.0" will be indicated.

(Reference)

You can also set the upper & lower limits by clicking on the number of digits and '/" buttons.

(4) Set the output.

1. Click the "OUTPUT" cell on the "N01" line.

- The setting detail for the output will appear.

2. Click "Y."

- A "Y0" will be displayed on the "OUT" cell of the "N01" line.
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3-4 Setting the output condition
Click the "OUTPUT CONDITIONS" from each measuring program setting screen. The "OUTPUT CON-

DITIONS" screen will appear.

Ë Operation details: When setting up the positional deviation measurement

Click the "OUTPUT CONDITIONS" on the position deviation measurement setting screen (page 3-2).

- The "OUTPUT CONDITIONS" screen for positional deviation measurement will appear.

æ Display of page 4

For details about these settings, see the "IV-S20 user’s manual: Chapter 10: PC Function."

Input signal
items to set

Logical symbol
items to set

Output s ignal
item to set

Click

Click this range on the
screen above. The page 4
will be displayed.



3-9

3

Chapter 3: Setting Object Type Conditions

IV
-S

20

[Example of settings]

Described below is the process used to create the example above.

1. Click the column 0 on the "INPUT 0" line (PAGE 0).

2. Click on the [–| |–] item in the "LOGICAL SYMBOL" area.

3. Click on the [MATCH M] item in the "INPUT SIGNAL" area.

- The selected input signal and logical symbol will be shown.

(Reference)

- Enter the registration number (0 to 7) and the object type number (0 or 1) by clicking the '/" arrows

(see above `).

4. To create the input section, click on the desired cell, logical symbol, and input signal repeatedly, the same

as in steps 1 to 3 above.

5. Click the column output on the "INPUT 0" line.

Click here

Click

Click

` (For reference of the below)

Click here
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6. Click on the [AUXILIARY C] in the "OUTPUT SIGNAL" area.

- The output signal and the auxiliary relay C000 will be shown in the table.

(Reference)

- Set the auxiliary relay number (0 to 127) by clicking the '/" item (`1) of auxiliary relay C, or directly

enter a number after double-clicking inside the relay number window (`2) to highlight the window.

Click `1`2
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Click

3-5 Operation example (positional deviation measurement)
This section describes the operation example for positional deviation measurement (2 points search) as

a use example of setting Object type conditions.

(1) Setting/operating of IV-S20

Let the IV-S20 to show the MAIN OPS MENU screen.

(2) Starting up IV-S20SP

- See page Setup-4.

(3) Communication settings

Set the protocols to communicate with the IV-S20.

- See "Chapter 2: Set Communication."

(4) Assign an object type number

Click the "Object type NO. (0 - 15)" from the "Object type COND" menu.

- The "OBJECT TYP..." dialog box will appear.

- Select the object type number (0 to 15) using the "/' buttons. Then click the "SET" button.

(5) Starting up the setting screen for the "Positional deviation measurement."

Click the "MEAS. 0 Camera 1" → "MEAS-POSITION-DEVIATE" items from the "Object type COND"

menu.

- The setting screen for the "Positional deviation measurement" will appear. (see the next page.)

Continued on the following page

Click

Click
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From the previous page

- Setting screen of positional deviation measurement

(6) Reading display images

1. Click the "Read image" → "Display image (Camera 1)" items from the "File" menu.

- The "Read display image (CAM 1)" dialog box will appear.

2. Click the "OK" button.

- The display image will be loaded. (See the next page.)

Click

Continued on the following page
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- An example of reading display image

(7) Mode settings

1. Specify a register number (0 to 7) using the '/" buttons, then click "YES" in the "REG." window.

- The measurement conditions for the mode (1 point search) will appear.

Continued on the following page

A register number
specification

Click
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The reference image

frame for the model 0

The reference image

frame for the model 1

The search area

frame for the model 0

The search area

frame for the model 1

From the previous page

2. Click the " item on the "MODE," and select "2 P-SCH" (2 points search).

- The measurement conditions for the mode (2 points search) will appear.

(8) Registration of the reference image

1. Drag the setting frame of the reference image or the search area using the mouse to define the

position.

- Example of settings

Click

Continued on the following page

The setting frame

for the reference

image (solid line)

The setting frame

for the search area

(dotted line)
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2. Click the "REG." button. Then click the "DISP" button.

- If an image is registered, its image will be displayed.

- Click the "DISP" button again to disappear the image.

æææææ Loading the measurement conditions to IV-S20

(9) Execute loading

1. Click the "Load" → "Set screen - IV" items from the "IV data settings" menu.

- The "IV data settings" dialog box will appear.

2. Click the "START" item on the "IV data settings" dialog box.

- The set measurement conditions will be loaded in the IV-S20.

After the loading is complete, the "Load all parameters completed (Set screen → IV)" will appear.

Registration (model 0)

Registration (model 1)

Display (model 0)

Display (model 1)

Click
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Chapter 4: Document Creation
You can automatically create a spreadsheet (table of the current parameters) using Excel or other standard

applications, so that you can easily manage and store parameter sets as documents.

4-1 Document creation (IV-S20 parameter)
This section describes the procedures for creating a document that contains parameters.

(1) Setting/operating the IV-S20

Bring up the MAIN OPS MENU screen on the IV-S20.

(2) Communication setting

Set the parameters for communicating with the IV-S20.

- See "Chapter 2: Set Communication."

(3) Loading the parameters

1. Click the "Save"  → "IV -> setting screen" items on the "IV data settings" menu.

- The "IV data settings" dialog box will appear.

2. Click the "START" button.

- The data set in the IV-S20 will be stored on the setting screen.

- After the saving data is complete, the "IV data settings" dialog box will appear.

3. Click the "OK" button.

Click here

Click

Click

Continued on the following page
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(4) Starting up the document creation screen

Click the "Creates a document" item from the "IV data settings" menu.

- The "Creates a document" dialog box will appear.

(5) Select a file

Click "Open" from the "File" menu on the "Creates a document" window.

- The "Open" dialog box will appear.

- When you want to create new file (with ".csv" extension) for making document, specify the folder

name, enter the file name, and click the "Open" button.

If you want to save it to an existing file, select the file and click the "Open" button.

(6) Document creation details

Select document type and the conditions and click the "Start creation" button.

- The program will create the document automatically. After the creation is complete, the "Creates a

document" dialog box will appear.

- Click the "OK" button on the box. (See page 4-4 for the example of the document creation.)

Click

Click

Select object

types Select

conditions

Click
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4-2 Document creation (file data)
This section describes the procedures for creating a document from the parameters already in a personal

computer file.

(1) Select a file in which to save the parameter settings

Click on "Select a file" on the "IV data settings" menu.

- The "Open" dialog box will appear.

- Select a file (with ".apm" extension) to create a document, then click the "Open" item.

(2) Reading the setting parameters

1. Click the "Load" → "File -> Set screen" items from the "IV data settings" menu.

- The "IV data settings" dialog box will appear.

2. Click the "START" button.

- The file data is loaded on the set screen.

For the following document creation processes after this, see the "4-1 Document creation (IV-S20

parameter)."

(See page 4-2 (4) to (6).)

Click

Click

Click
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[Example of document creation]

Shown below is an example which a document file (with ".csv" extension) that contains the condi-

tions for each object type and can be opened using Excel.

<<< Object type number 00 >>>
TITLE� SAMPLE
---- Main ----
MEAS.0, CAMERA 1� POSITIONAL DEVIATION MEASUREMENT
MEAS.0, CAMERA 2� NO
MEAS.1� NO
MEAS.2� NO
MEAS.3� NO
HALT MEAS ON NG� NO
POS. ADJ.CAMERA 1� NO CALIBRATION
POS. ADJ.CAMERA 2� NO CALIBRATION

---- Positional deviation measurement (Camera 1) ----
[MEAS. PROG. COND]
* Registration number�� 0
Mode� 2 point search
<First point>
MEAS WINDOW� RECTANGLE
REF IMAGE upper left X COORD�� 68
REF IMAGE upper left Y COORD�� 232
REF IMAGE lower right X COORD�� 139
REF IMAGE lower right Y COORD�� 295
SEARCH AREA upper left COORD�� 60
SEARCH AREA upper left COORD�� 224
SEARCH AREA lower right COORD�� 147
SEARCH AREA lower right COORD�� 303
DTECT COORD�  CNTR
DTECT COORD (X)�� 104
DTECT COORD (Y)�� 264
CONTR. PIXEL�� 3
<Second point>  
MEAS WINDOW� RECTANGLE
REF IMAGE upper left X COORD�� 356
REF IMAGE upper left Y COORD�� 232
REF IMAGE lower right X COORD�� 427
REF IMAGE lower right Y COORD�� 295
SEARCH AREA upper left COORD�� 348
SEARCH AREA upper left COORD�� 224
SEARCH AREA lower right COORD�� 435
SEARCH AREA lower right COORD�� 303
DTECT COORD�  CNTR
DTECT COORD (X)�� 392
DTECT COORD (Y)�� 264
CONTR. PIXEL��  3
DETECT ACCURACY� STANDARD
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Chapter 5: Data Collection
You can transmit the measurement result data from the IV-S20 to a personal computer via a communication

(general purpose serial I/F), and automatically create a result sheet.

The data collection function is used to manage or save measurement data, and collect data settings such as

the evaluation conditions.

This chapter explains the operation procedures for the data collection.

(1) Setting/operation of the IV-S20

1. Set the serial output (input/output conditions) on the IV-S20 to "general purpose serial."

2. Return to the MAIN OPS MENU screen.

(2) Communication settings

Set the protocols to communicate with the IV-S20.

- See the "Chapter 2: Set Communication."

(3) Starting the data collection screen

Click on the "Data collection" item in the "IV data settings" menu.

- The "Data collection" dialog box will appear.

Continued on the following page

Click here

On the "MAIN OPS MENU", move the cursor to SET-SCRN, and press the SET key.

- On the [SYSTEM SETUP] menu, moves the cursor to item 3 I/O CONDITIONS 

and press the SET key.

①MEAS TRIG INP I/F PARALLEL  SERIAL  CCD-TRG

③SERIAL OUTPUT� NO　PC-LINK　SERIAL
   (INPUT=PARALLEL)
④CHG MEAS NO.X5,X6�NO　YES
⑤PARALLEL INPUT X5�EXT-INP.  REG-REF-IMG(MSR0)
⑥PARALLEL INPUT X6�EXT-INP.  CHG-IMG-OUT-CAM
⑦OUTPUT STATUS� BUSY　READY
⑧SERIAL CONDITIONS(TO NEXT SUB-MENU)
⑨COMPUTER LINK� (TO NEXT SUB-MENU)
⑩GAIN-OFFSET� (TO NEXT SUB-MENU)
⑪UPPER MENU

［I/O CONDITIONS］ 
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From the previous page

(4) File selection

Select the "Open" item from the "File" menu on the "Data collection" dialog box.

- The "Open" dialog box will appear.

- When you want to create a new file (with ".csv" extension) to save the collected data, specify the folder

name, enter the file name, and click the "Open" button.

If you save the collected data to an existing file, select the file and click the "Open" button.

(5) Setting the data collection conditions

1. Click on the "Setup" button.

- The setting conditions for the IV-S20 will be loaded.

2. Select the items for data collection.

Cl ick
here

Click
here

Continued on the following page
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(6) Execute a data collection

Click on the "START" button.

- The data collection from the IV-S20 will start.

(7) Creation of a data collection table

1. Click on the "Cancel" button.

- The data collection will stop.

2. Click on the "Create a data list" button.

- The total file of the data collected will be created automatically. After the creation ends normally,

the "Total data creation is complete" message will appear.

Note

- If processing speed of a personal computer is slower than the data transmission speed of the IV-

S20, some parts of the data may be lost.

1 2

Click
here
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[Data collection example]
Shown below is an example in which the graph creation feature in Excel is used to make a graph of the

data file (with ".csv" extension) created with the data collection function.

Example: Measuring an area by binary conversion, and setting the upper and lower limits for the evalu-

ation conditions of the surface area.
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Create a table using Excel.

Create a graph using Excel.

Data file (with ".csv" extension)
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Chapter 6: Reading/Writing Parameters and Images
Setting parameters and images (display images/messages) can be stored in a personal computer. Uploading

and downloading of the setting parameters is also available.

- This function can be used to evaluate samples locally by transmitting setting parameters saved in a file via E-

mail or other means of communication.

It can be also used to create copies of settings by reading or writing the setting parameters.

Ë Loading/saving/verifying setting parameters

By selecting the "Load," "Save" or "Verify" item from the "IV data settings" menu, the operations below is

available.

Ë Read/write image

By selecting the "Read image" or "Write image" item from the "File" menu, the operations below is available.

6-1 Saving setting parameters
Select the "Save" item from the "IV data settings" menu. The operation item below will appear.

Setting
parameters

Load

Save

Verify

Operation items

File -> IV
File -> Set screen
Set screen -> IV
IV -> File
Set screen -> File
IV -> Set screen
File <-> IV
File <-> Set screen
IV <-> Set screen

Section on this
chapter for reference

6-3

6-1

6-2

Image

Read image

Write image

Operation items

Message

Message

Display image (Camera 1)
Display image (Camera 2)

Display image (Camera 1)
Display image (Camera 2)

Reference section
on this chapter

6-4 [1]

6-4 [2]

Save
IV -> File

Set screen -> File

IV -> Set screen

Operation details
Save the setting parameters of the IV-S20 to the file of the personal computer.
Save the setting parameters of the set screen to the file of the personal computer.
Save the setting parameters of the IV-S20 to the set screen of the personal
computer.
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Below describes the operation procedures to save (IV -> File) the IV-S20 setting parameters to the file in the
personal computer.

(1) Setting/operating of IV-S20

Let the IV-S20 to show the MAIN OPS MENU screen.

(2) Communication settings

Set the protocols to communicate with the IV-S20.

- See "Chapter 2: Set Communication."

(3) File selection

Click the "Select a file" item from the "IV data settings" menu.

- The "Open" dialog box will appear.

- When you want to create new file (with ".apm" extension) for saving setting parameters, specify the

folder name, enter the file name, and click the "Open" button.

If you want to save it to an existing file, select the file and click the "Open" button.

(4) Saving all parameters

1. Click the "Save" → "IV -> File" items from the "IV data settings" menu.

- The "IV data settings" dialog box will appear.

2. Click the "START" button.

- All setting data in the IV-S20 will be saved to the specified file (enter the file name above.)

When the saving is complete, the "IV data settings" dialog box will appear.

3. Click the "OK" button.

Click

Click

Click

Click
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6-2 Verifying setting parameters
Select the "Verify" item from the "IV data settings" menu. The operation item below will appear.

Below describes the operation procedures to verify (File <-> IV) the PC file with the IV-S20 setting pa-

rameters.

(1) Setting/operating of IV-S20

Let the IV-S20 to show the MAIN OPS MENU screen.

(2) Communication settings

Set the protocols to communicate with the IV-S20.

- See "Chapter 2: Set Communication."

3) File selection

Same as the procedures section 6-1. - See page 6-2.

(4) Saving all parameters

1. Click the "Verify" → "File <-> IV" items from the "IV data settings" menu.

- The "IV data settings" dialog box will appear.

2. Click the "START" button on the "IV data settings" dialog box.

- All setting data in the IV-S20 and the personal computer specified file will be verified.

When the verifying is complete, the "IV data settings" dialog box will appear.

Click the "OK" button.

Verify Operation details
Verify the personal computer�s file (setting parameters) with the IV-S20 setting
parameters.

Verify the personal computer�s file (setting parameters) with the set screen
setting parameters.

Verify the IV-S20 setting data and the personal computer set screen setting
parameters.

File <-> IV

File <-> Set screen

IV <-> Set screen

Click
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6-3 Loading setting parameters
Select the "Load" item from the "IV data settings" menu. The operation item below will appear.

Below describes the operation procedures to load (File <-> IV) the setting parameters from the personal

computer’s file to the IV-S20.

(1) Setting/operating of IV-S20

Let the IV-S20 to show the MAIN OPS MENU screen.

(2) Communication settings

Set the protocols to communicate with the IV-S20.

- See "Chapter 2: Set Communication."

(3) File selection Same as the procedures section 6-1. - See page 6-2.

(4) Loading all parameters

1. Click the "Load" → "File -> IV" items from the "IV data settings" menu.

- The "IV data settings" dialog box will appear.

2. Click the "START" button on the "IV data settings" dialog box.

- The personal computer’s specified file (setting parameters) will be loaded to the IV-S20.

When the loading is complete, the "IV data settings" dialog box will appear.

Click the "OK" button.

Click

Loading Operation details
Load the setting parameters from the personal computer’s file to the IV-S20.
Load the setting parameters from the personal computer’s file to the personal
computer set screen.

Load the setting parameters from the personal computer set screen to the
IV-S20.

File -> IV

File -> Set screen

Set screen -> IV
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6-4 Reading/writing images
[1] Reading images (display images and messages)

Select the "Read image" item from the "File" menu. The operation item below will appear.

Below describes the operation procedures to read display images (camera 1) of the IV-S20 to the PC set

screen and save it to the personal computer’s file.

(1) Setting/operating of IV-S20

Let the IV-S20 to show the MAIN OPS MENU screen.

(2) Communication settings

Set the protocols to communicate with the IV-S20.

- See "Chapter 2: Set Communication."

(3) Loading display images

1. Click the "Read image" → "Display images (Camera 1)" items from the "File" menu.

- The "Read display image (CAM1)" dialog box will appear.

Read image Operation details
Read the display images (camera 1) of the IV-S20 to the personal computer set
screen.

Read the display images (camera 2) of the IV-S20 to the personal computer set
screen.

Read the display messages of the IV-S20 to the personal computer set screen.

Display image
(Camera 1)

Display image
(Camera 2)

Message

Click

Continued on the following page
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2. Click the "OK" button on the "Read display image (CAM1)" dialog box.

- The camera image of the IV-S20 will be transmitted and displayed on the personal computer’s

image display area.

(Example of display)

(4) Saving the image as an image file (.bmp format)

Click the "Save" → "Image only" items from the "File" menu.

- The "Save as" dialog box will appear.

- When you want to create new file (with ".bmp" extension) for saving an image file, specify the folder,

enter the file name, and click the "Save" button.

If you want to save it to an existing file, select the file and click the "Save" button.

- The image file will be stored in the specified file.

Click
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[2] Writing images (load images)
On the "RUN MENU SETTINGS" menu of the IV-S20, select "NO" in the "CAPTURE AN IMAGE." You can

measure using the loaded images from the personal computer.

- Transmit the image files over a communication cable to evaluate samples and inspect troubles on remote.

- You can process images using the PHOTOSHOP or PAINT SHOP PRO application, and load it to the IV-

S20 as a gray scale, 8 bit BMP file.

Select the "Write image" item from the "File" menu. The operation item below will appear.

Below describes the operation procedures to write displayed images on the PC screen to the IV-S20 (cam-

era 1.)

(1) Setting/operating of IV-S20

1. On the "RUN MENU SETTINGS" menu of the IV-S20, select "NO" in the "CAPTURE AN IMAGE."\

2. Let the IV-S20 to show the MAIN OPS MENU screen.

(2) Communication settings

Set the protocols to communicate with the IV-S20.

- See "Chapter 2: Set Communication."

Write image Operation details

Write the displayed image on the PC to the IV-S20 (camera 1).

Write the displayed image on the PC to the IV-S20 (camera 2).

Display image(Camera 1)

Display image(Camera 2)

Continued on the following page

On the "MAIN OPS MENU", move the cursor to "SET-SCRN" item, and press the "SET" key.

- On the [SYSTEM SEUP] menu, move the cursor to "1 RUN MENU SETTINGS" and 

press the "SET" key.

［RUN MENU SETTINGS］ 

1MONITOR OUTPUT�CAM1 CAM2 CAM1&2
2CAMERA1&2� CAM1=MD CAM2=MD
3CAPTURE AN IMAGE�PARTIAL-IMAGE  WHOLE-IMAGE  NO
4MESSAGE DISPLAY� YES(RESULT.OK) YES(RESULT.NO) NO
5PATTERN DISPLAY�MEAS-RESULT- OUT　NO
6SHOW BINARY IMAGE�YES　NO
7SHOW CORRECT IMG YES　NO
8DISPLAY + CURSOR�NO　YES
9OBJ.NO.MANL MODE�NO　YES
0UPPER MENU
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(3) Loading display images

1. Click the "Write image" → "Display image (Camera 1)" items from the "File" menu.

- The "Write display image (CAM1)" dialog box will appear.

2. Click the "OK" button on the "Write display image (CAM1)" dialog box.

- The image displayed on the PC will be written to the IV-S20 (camera 1).



Chapter 7: Command Test

7-1

7

IV
-S

20
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On the "MAIN OPS MENU", move the cursor to SET-SCRN, and press the SET key.

- On the [SYSTEM SETUP] menu, moves the cursor to item 3 I/O CONDITIONS and press the 

SET key.

1MEAS TRIG INP I/F� PARALLEL  SERIAL  CCD-TRG�
�
3SERIAL OUTPUT� NO　PC-LINK　SERIAL�
   (INPUT=PARALLEL)�
4CHG MEAS NO.X5,X6�NO　YES
5PARALLEL INPUT X5�EXT-INP.  REG-REF-IMG(MSR0)
6PARALLEL INPUT X6�EXT-INP.  CHG-IMG-OUT-CAM
7OUTPUT STATUS� BUSY　READY�
8SERIAL CONDITIONS(TO NEXT SUB-MENU)
9COMPUTER LINK� (TO NEXT SUB-MENU)
0GAIN-OFFSET� (TO NEXT SUB-MENU)
qUPPER MENU

［I/O CONDITIONS］�

Continued on the following page

Chapter 7: Command Test
The command test function is used to communicate to the IV-S20 through the serial interface and confirm that

communication has been established when the personal computer is starting started.

This chapter describes the command test procedures.

(1) Setting/operating of IV-S20

1. On the "I/O CONDITIONS" menu on the IV-S20, select "SERIAL" in the "SERIAL OUTPUT" item.

2. Bring up the MAIN OPS MENU screen.

(2) Communication settings

Set the protocols for communication with the IV-S20.

- See "Chapter 2: Set Communication."

(3) Starting the command test screen

Click on the "Command Test" item on the "File" menu.

- The "Command test" dialog box will appear.
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(4) Setting the conditions for the command test

In the "Command test" dialog box, set the conditions for the command test (set time out, checksum, and

number of repeats).

(5) Transmitting serial commands

Enter the data to send in the "Command test" dialog box, and press the [Enter] key or click the "Data

transfer" button.

- The data will be transmitted to the IV-S20. The response data will be displayed in the receive data

area.

Reference: Click the "Data Clear" menu to delete the displays of the sending data, the receiving data,

and the checksum values.

Setting details Description

30 sec.
Setting the

time out
60 sec.

Checksum Manual

Fixed (@@)

2 timesNumber of
repeats

3 times

Others

Wait 10 seconds for a response.
Wait 30 seconds for a response.
Wait 60 seconds for a response.
A checksum is automatically created when data is transmitted.
An operator counts a checksum, and attach it to a send data
directly before transmitting.

A checksum is not executed, and @@ will be transmitted.
The data transmission terminates with one time even a
communication error occurs.

The data transmitted until twice when a communication error occurs.
The data will be transmitted until three times when a
communication error occurs.

The number of repeats can be set over four times.

10 sec.

Automatic

- The "    " indicates the default setting.

1 time

Click

Click here

Enter the data

to send

Display the

data received

Checksum

values

Continued on the following page
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(6) Saving/loading files

- Saving the data received to a file

1. Click on the "Select a file" item in the "File" menu.

- The "Open" dialog box will appear.

- When you want to create a new file (with ".tst" extension) to save the data received, specify the

folder name, enter the file name, and click on the "Open" button.

If you want to save it to an existing file, select the file and click on the "Open" button.

2. Click on the "Save" item in the "File" menu.

- Loading the receiving file from a file

1. Click the "Select a file" item from the "File" menu.

- The "Open" dialog box will appear.

Select the loading folder or file (with ".tst" extension) name.

2. Click the "Load" item from the "File" menu.
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Set key (SET)
Left key (\)

［IVS20  VERSION  UP  MENU］
1SYSTEM RECEIVE� RUN
2SYSTEM TRANSFER� RUN
3BOOT RECEIVE� RUN
4BOOT TRANSFER� RUN
5ALL INITIALIZE� RUN
6POWER ON RESET� RUN

Chapter 8: Upgrade Version
To upgrade the IV-S20 system version (improved functions) you simplydownload the new version from a per-

sonal computer.

- The IV-S20 software consists of the "system program," used to set up and execute image processing opera-

tions, and a "boot program" to load the other programs. In some cases, both programs need to be upgraded.

(Refer to our sales department for the latest version of the system software.)

Described below are the procedures for upgrading the program version.

(1) Preparation

Create the folders below for installing the software.

SVXXX.mot VXXX system program 
  (X is different between versions.)

BVXXX.mot VXXX boot program

(2) Communication settings

Set the protocols for communication with the IV-S20.

- See "Chapter 2: Set Communication."

(3) Setting/operating of IV-S20

1. Turn on the IV-S20.

- Turn on the IV-S20, while pressing and holding down both the left key (\) and the set key (SET) on

the remote key pad at the same time.

- The IV-S20 upgrade version menu (IVS20 VERSION UP MENU) will appear on the monitor.

2. Select the upgrade version menu.

- Move the up and down keys to select the "1 SYSTEM RECEIVE" item and press the set key

  (SET).

(The "3 BOOT RECEIVE" item may also be needed to perform the upgrade, depending on the

upgrade conditions.)
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(4) File selection

Click on the "Select a file" item on the "Version up" menu.

- The "Open" dialog box will appear.

- Select the SVXXX.mot file and click on the "Open" button.

(5) Transmission

Click the "Transfer data Without INIT" item from the "Version up" menu.

- Transmission is started.

- When the [  ON RECEIVE ] message appears on the IV-S20 monitor and the [  ] flashes, the

transmission has been successful.

- It takes approximately five minuets to transmit the file from a Pentium 266 MHz personal computer.

- When the [  ON RECEIVE ] display disappears, the new system program has been successfully

written to the flash memory.

(6) Starting the g new version of the system

Move the up and down keys to select "6 POWER ON RESET" on the IV-S20 upgrade version menu

(displayed on the monitor) and press the [SET] key.

- The power to the IV-S20 will be reset and the new version of the system program will start.

Click

Click

［IVS20  VERSION  UP  MENU］
1SYSTEM RECEIVE� RUN
2SYSTEM TRANSFER� RUN
3BOOT RECEIVE� RUN
4BOOT TRANSFER� RUN
5ALL INITIALIZE� RUN
6POWER ON RESET� RUN
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Chapter 9: Additional Descriptions
This chapter describes additional description; copy to the clipboard, changing the message display color, and

changing the image brightness.

[1] Copy to the clipboard
The displayed images can be copied to the Windows95/98 clipboard.

- To paste a display image into an Excel or Word file, click "Paste" on the "Edit" menu of Excel or Word. The

image will appear at the cursor in the active document.

(Word and Excel are registered trademarks of Microsoft Corporation.)

(Operation procedures)

1. Move the cursor to "Copy display image" on the "Edit" menu.

2. Select the object to copy.

Click "Image only," "Message only," or "Image + Message."

- The object will be copied to the Windows95/98 clipboard.

[2] Changing the message display color
You can select one of 8 colors for the display image color. If the image and the message are same colors,

use a different message color to allow you to see the message.

- The colors you can chose from are black, blue, green, cyan, red, magenta, yellow, and white.

- If you display images and messages, set the image brightness to "Half," and select a white message

display color. Then, you can easily view the screen.

- If you are only going to display messages, change message display color to black, so that you can paste

the messages to a clipboard or into other documents.

(Operation procedures)

1. Move the cursor to "Message color" on the "Edit" menu.

2. Select a color.

Select the desired color. (Default: black)

- The message color will be changed.
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[3] Changing the image brightness
You can set the displayed image brightness to "Normal" or "Half."

- When you display "Image + Message," select the image brightness to "Half." (Message color is "white.")

(Operation procedures)

1. Move the cursor to the "DISP image bright level" item on the "Edit" menu.

2. Select a brightness.

- Click on "Normal" or "Half." (Default: Normal )

- The displayed image will be changed to the selected brightness.
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Error code
If an error occurs and an error code appears while operating the IV-S30SP, use the error code list below for

details about the error.

For information about error codes not listed above, see "Cause and Treatment of a termination code (when an

error occurs)" in the user's manual for the IV-S31MX/S32MX/S33MX, or IV-S20).

edocrorrE esuacelbissoP

7 .noitarepoevasehtmrofrepotyromemhguonetoN

9 .egnarevitceffeehtedistuosideretneretemarapehT

31 .esuotelbaebotsutatsehtnitonsiatadehT

25 .dnuofebtonnacemanelifehT

35 .elifderiuqerehtdniftonnaC

55 .nepoydaerlasielifdetcelesehT

16 .ecapscsidhguonetonsierehT

26 .elifehtniataderomonsierehT

07 .atadehtetirwotelbanU

17 .ydaertonsiksidehT

57 .emanhtapdilavnI

083 .eulavretemaraptcerrocnI

184 .erutcipytluaF

584 .tamroferutcipelbatpeccanU

2008 .rebmuntropdilavnI

5008 .denepoydaerlasitropehT
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